Starter issues - Honda Pioneer Forum
 
LinkBack Thread Tools
post #1 of 3 Old 06-19-2016, 10:17 AM Thread Starter
Junior Member
 
Join Date: Apr 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Starter issues

I recently went to take my 700 out and it wouldn't start. Tried jumping it off and nothing. Checked the battery and it appears the batter is fine. Replaced the main fuse and still nothing. I'm not even getting anything on the dash when I turn the key. Any ideas?
Maverick2484 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-20-2016, 08:58 AM
Senior Member
 
Join Date: Feb 2015
Location: NH
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
How did you check the battery? If you used a typical volt meter and it shows a good voltage does not always mean the battery is good. I'd start by checking the wiring coming off the battery and make sure all the connections (included all the grounds) are clean and tight.

Red '15 700/4
allgm1 is online now  
post #3 of 3 Old 06-20-2016, 08:24 PM
Junior Member
 
Join Date: Dec 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
allways check the grounds first
hondaman1 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome