Honda Pioneer Forum banner
1 - 20 of 22 Posts

·
Premium Member
Joined
·
1,602 Posts
If you can get them separate let us know what they cost. If they are the same as the ones on the windshield they are friggin nice clamps, I'd like to get a couple for mounting lights. I am surprised it broke.
 

·
Registered
Joined
·
658 Posts
If you cant get any there at the dealer I ran into some polaris clamps that are similar they work great but you cant use all the rubber that come with it I cut a small section to cover what I call the foot side. This week im building a basket and doing some load testing.

Search Results - Rocky Mountain ATV/MC
 

·
Registered
Joined
·
658 Posts
yeah none of the websites around the house have that clamp on there site. hey hickunit can you give us a part number when you get the clamp in?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
Yep got one in Red a couple weeks ago...I called every dealership in Maine and there was literally only one in the entire state in stock...a lot of places would take down payments...

I put a hard roof and half windshield on it so far....
Have to install the KFI 4500lb winch and LED light bars I just got next...

Our trails dont open until May 15th so I have to just ride around the yard with it for now...
 

·
Registered
Joined
·
658 Posts
sweet. a bed extender is nice to have I just got mine in and love it. might spped up your clamps also.
 

·
Registered
Joined
·
355 Posts
Is the rubber insert in the clamp for shipping or are you supposed to leave it there
 

·
Premium Member
Joined
·
1,602 Posts
I though it was just to hold the clamp together for shipping. I used that area of the clamp to run the wire loom coming from the Sasquatch light down the roll bar to help hide it and holds it behind the bolt. Looks real clean.

Don't throw them away, they will come in handy for something.
 

·
Registered
Joined
·
12 Posts
on the rubber piece, take them out and leave them out. I learned that the hard way with my roof on p2 flapping in air on interstate. Dealer actually found lost bolt of clamp (i thought my clamp broke). I took the rubber pieces out, tighten all clamps and have done 90mph plus with no troubles on long haul now. I have full windshield and hard roof. Dealer should have some clamps. Hope this helps.
 
1 - 20 of 22 Posts
Top